Monday, October 25, 2010

Installing Redmine for Windows Server in 10 minutes

1. Download version 1.8 of Ruby – the link is to the “all-in-one” installer for Windows. You need version 1.8, not 1.9 as Redmine only works on 1.8 right now.
2. Set up so Ruby’s “bin” folder is in your system or command prompt path. You should be able to type “ruby” at the command prompt and not get any “file not found” errors.
3. Create yourself some sort of “Ruby apps” folder and open a command prompt at that location, e.g. C:\Ruby\Apps or something
4. At the command prompt: “gem install rails“
5. At the command prompt: “gem install mongrel“
6. At the command prompt: “gem install rack -v=1.0.1“
7. At the command prompt: “gem sources -a“
8. At the command prompt: “gem install win32-service --platform mswin32“
9. At the command prompt: “gem install mongrel_service --platform i386-mswin32“
10. Download the latest stable version of Redmine and unzip into a subfolder of your Ruby apps dir (e.g. C:\Ruby\Apps\Redmine)
11. Configure the database.yml for Redmine to point to a database for your Redmine instance to use (I’ll leave that up to you)
12. If you’re using Redmine v0.8.7 or above, at the command prompt: “rake generate_session_store”
13. In the Redmine folder, at the command prompt: “rake db:migrate RAILS_ENV=production“
14. Test your Redmine installation is working, at the command prompt: “mongrel_rails start“, then hit http://localhost:[port]/ in your browser where [port] is the port Mongrel started with. Kill the server with Ctrl+C once you’ve verified Redmine is working.
15. Install Redmine as a Windows service, at the command prompt: “mongrel_rails service::install -N Redmine -c [your redmine folder] -p [portno] -e production“, replacing [your redmine folder] with the full path to the Redmine folder in the filesystem, and the [portno] being the port you’d like redmine to server on, e.g. 80 for standard http port 80.

Warning: With the latest version of MySQL, you may get several errors such as: "!!! The bundled mysql.rb driver has been removed from Ruby 2.2" and when you try to do "gem install mysql" you may also get many errors. Attempting to perform any rake commands subsequently fail. One possible solution:
Try to download the following DLL file from the InstantRails project:
Copy this file into your \Ruby\bin directory and try running your rake commands again.

Monday, October 18, 2010

Flash plugin for 64 bit Ubuntu 10.04

Use the Adobe Flash PPA and install the flashplugin64-installer package. You can do this by copying and pasting the following into a terminal:
sudo add-apt-repository ppa:sevenmachines/flash 
&& sudo apt-get update 
&& sudo apt-get install flashplugin64-installer
You will need to restart your browser after installing for Flash to work.